Log in User page Discussion History Go to the site toolbox

User talk:Sam Odio/Ashelley/Known Issues

From BluWiki

These are issues with the new server (named Ashelley). If you find an issue not listed here, please add it.

Unicode support broken (horribly)

Our group likes to add random Chinese/Japanese/Russian characters to our pages, and I've noticed that whenever the pages are edited, those characters get turned into ?. Apparently, what's being displayed and what's being saved are different (somehow); if you go to a page and add some random Chinese characters (pick a couple from Chinese Wikipedia, provided you can actually see the characters and not just question marks or boxes), and save it, it looks fine. But when you go to edit it again, all you see are question marks. Worse, when you save it, if you made any changes, those question marks replace the Chinese characters. I wonder if this can be fixed? It's probably a simple, accidental over-application of character-set conversion *somewhere* along the line. nneonneo 22:48, 19 April 2008 (EDT)

Thanks, I'll look into this. --Sam Odio 23:22, 19 April 2008 (EDT)
Appears to be resolved. All existing characters are now broken, but at least when we fix them, they'll stay correct :) nneonneo talk 21:05, 30 April 2008 (EDT)
Great. Let me know if the error occurs in the future --Sam Odio 09:05, 1 May 2008 (EDT)
Broken again... nneonneo talk 20:42, 8 May 2008 (EDT)

My account is borked

User:nneonneo can't edit any pages (I'm writing this message while logged out). The error is

Fatal error: Call to undefined function xml_parser_create() in /var/www/bluwiki-org/htdocs/includes/XmlFunctions.php on line 238

Can it be fixed? nneonneo talk 18:35, 24 April 2008 (EDT) (posted from 70.64.98.110)

I definitely should be able to fix this - we just upgraded PHP versions and it broke some things. Give me a week though, I'm on vacation in Costa Rica and can't do any serious work remotely. --Sam Odio 20:42, 24 April 2008 (EDT)
OK, so I took a peek at MediaWiki, and it looks like the only place where this function gets called is in wfIsWellFormedXml, which in turn is only called by wfIsWellFormedXmlFragment, which in turn is only called by validateSig. nneonneo is using a raw signature, and this causes it to fail. Using a regular signature works, and trying to set a raw signature now fails too. nneonneo talk 23:20, 25 April 2008 (EDT) (posted by nneo)
As you can see, this is now resolved. Thanks! nneonneo talk 21:05, 30 April 2008 (EDT)
Great. I added XML support to the new server. Let me know if you have problems in the future. --Sam Odio 09:04, 1 May 2008 (EDT)
The problem has returned. talk 00:03, 7 May 2008 (EDT) (posted from 128.233.110.121)
This problem should only exist on http://bluwiki.com and http://www.bluwiki.com - and I'm currently working to fix it. If it exists on other subdomains (i.e. http://packrat.bluwiki.com/go/Main_Page) - let me know, because my fix won't work. --Sam Odio 01:39, 7 May 2008 (EDT)
I believe I fixed the problem on the second server - however it make take 12hrs for the cache to update. If you're still experiencing it after 12 hrs, let me know --Sam Odio 03:23, 7 May 2008 (EDT)

(outdent) Yes, it appears to be fixed. Thanks for the prompt reply! nneonneo talk 20:08, 6 May 2008 (EDT)

Error creating thumbnails

Any attempt to create a thumbnail results in this error:

Error creating thumbnail: /usr/bin/convert: error while loading shared libraries: libSM.so.6: failed to map segment from shared object: Cannot allocate memory

Existing thumbnails work. --Sam Odio 18:46, 30 April 2008 (EDT)

Solved, images can now be resized successfully. --Sam Odio 21:43, 2 May 2008 (EDT)

Special characters not displaying

Pages that had special characters (such as é ô, etc). The solution right now is to manually replace the characters. See this edit for an example --Sam Odio 18:55, 30 April 2008 (EDT)

OK, there's another problem. A couple of pages which were *named* with special characters (Template:· for example) got their names corrupted, making them completely inaccessible; see link: this page redirects to Template:· but it shouldn't; the new template page is different from the old one. The old page is now completely inaccessible. Also, as a minor issue, I can't remove it from my watchlist ("invalid title"). nneonneo talk 21:42, 30 April 2008 (EDT)

Watchlist e-mails not being sent.

As the subject says. I have no other information to add. � Nathan (talk) 05:07, 1 May 2008 (EDT)

I think I got email working - let me know if you start receiving notices of changes to watchlist pages. --Sam Odio 08:37, 1 May 2008 (EDT)
Works great, thanks. � Nathan (talk) 08:48, 1 May 2008 (EDT)

Two word page name problem

Browsers seem to be having a problem accessing pages with two words in the page name e.g. http://fruit_wine.bluwiki.com -I get the message "400 - Bad Request" I've tried a few different pages with the same result. BTW thanks for protecting my pages. --wildplum 05:42, 10 June 2008 (UTC)

Site Toolbox:

Personal tools
GNU Free Documentation License 1.2
This page was last modified on 10 June 2008, at 05:42.
Disclaimers - About BluWiki